English  Deutsch
Biosolar Forum  =>  Mérésadatgyűjtés  =>  Single Board Computer - 1Wirelapozz: « előző   1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34   következő »
Mielőtt kérdezel olvasd el a témához tartozó KIEMELT CIKKEKET!
2010-12-26
13:55:32
#9982
"elvileg a vezerles frissiti az RRD-ket, es 5 percenkent csinal ebelole egy friss grafikont"

Én röptében készítem a grafikont, így nem kell ütemezetten tárolni, meg létrehozni:

<?php
header("Content-type:image/png");
passthru("LANG=hu_HU.UTF-8; export LANG; rrdtool graph -i -W Takyka $limits $ytext $title $start $end - $lines -w $graph_width -h $graph_height");


T.
2010-12-25
21:35:34
#9974
Na, valamit csinaltam:)

www.i-house.hu/haz/rrd/location_3.png

elvileg a vezerles frissiti az RRD-ket, es 5 percenkent csinal ebelole egy friss grafikont

majd meg csinalok hozza napi/heti/havi/eves bontast, meg valami egyszeru HTML oldalt, ami egyszerre megjeleniti, mint a munin, de egyelore orulok most ennek is:)

koszi, a LINE2 utani resz hianyzott neki.

2010-12-25
18:01:40
#9971
Szia,

Így néz ki egy sor:

LANG=hu_HU.UTF-8; export LANG; rrdtool graph -v C° --title "HMV keringetes allapot" --start end-1d --end now - DEF:a="/srv/rrd/hmv.rrd":hmv:AVERAGE LINE2:a#ff0000:"HMV hömérséklet a csöben" -w 400 -h 100

Eddig még soha nem adtam meg az imgformat opciót, mindig png-t csinált. :-)

szerk:
www.linux.die.net/man/1/rrdgraph itt azt írja, hogy nagy betűkkel kell megadni a képformátumot.

T.
2010-12-25
10:33:47
#9969
takyka:

rrdtool graph nekem ezt mondja:

rrdtool graph location_1.png --imgformat png DEF:ds0=location_1.rrd:temp:AVERAGE

unsupported graphics format 'png'

te milyen parameterekkel generalod a grafikonokat?

2010-12-22
10:02:11
#9912
robert:

mint irtam regebben is, van/volt kulso szenzorom, de 0 fok alatt nem mert!

most azt hiszem pont nincs bekotve, de egyebkent van.

2010-12-21
10:23:21
#9881
zsezse,
Hogy miért? Azért, hogy a külső hőmérsékletet is mérni lehessen. A külső hőmérsékletet talán nem használod a vezérléshez, de a statisztika miatt fontos.
2010-12-21
10:06:42
#9879
robert:

miert? mar csatlakozgtattam sajat szenzorokat is.
majd az uj helyre, ahol csak 1wire lesz, ott megprobalom
2010-12-21
08:12:06
#9877
zsezse,
Csatlakoztass még egy ds1820-at.
2010-12-20
22:22:24
#9875
ez a sensor mereshatara: 0-128fok

legalabbis 0 fok alatt nem ad ki adatot
2010-12-17
14:57:18
#9812
robert

van, de 0 fok alatt nem mer:( csak 0-128 C fokig.
2010-12-17
08:48:55
#9804
Zsezse,

rrdtool-al csinálom az adatok rögzítését is és a grafikonokat is. Ott van a bináris csomagok között.

T.
2010-12-17
08:33:35
#9803
zsezse,

Nálunk a grafikon készítés szerver oldalon megy (ezért nem kell felturbózni az openwrt-t), de egyszer próbáltam (nem emlékszem a nevére) egy java rajzolót, ami a browser oldalon végzi el ezt a munkát.

Jó lenne, ha felraknál egy külső hőmérséklet szenzort is a ház árnyékos oldalán.

2010-12-16
22:33:37
#9802
ujra elerheto:

www.i-house.hu/haz/online/


ti mivel gyartotok grafikont?
openwrt alatt lenne jo megoldani, hogy kompakt megoldas legyen, de sajna munin nincs csak muninlite:(
2010-12-16
21:53:27
#9801
sziasztok
jelentem, beuzemeltem a padlason az uj RSPROt:)))
felhuztam neki egy 12 eres riasztokabelt, 7 er a GPIOnak, 2 er az USBnek tap gyanant (+5V)

eddig ugy nez ki minden tervszeruen mukodik! most tesztelem, a router szerepet mar atvette!
valamiert az 5Vot nem viszi at rendesen kb 12m kabelen kellene atmenni, de nem "gyujtanak be" az optocsatolok vagy a triakok;(


2010-12-08
13:58:25
#9564
szasza_1,

Csak egyféle áramköröm van. Működik jól, jelen pillanatban két modul van használatban kimenetként, összesen három kimenettel. két db 6A-es egymorzés relé van beletervezve. e-mailt küldök.

T.
szasza_1Válasz erre
2010-12-06
22:25:40
#9490
Szia takyka!

Az általad tervezett IO modulokról szeretnék érdeklődni. Jól működnek? Főként a 230V-os eszközök ki-be kapcsolásához való 1-wire relé érdekelne, de többi áramkörre is kíváncsi lennék.
2010-12-06
16:24:50
#9470
robert:

most 2 panel van itt nalam, az RS az mukodik, arrol megy minden, ezert azt nem akarom kicserelni:)
az RSPRO menne vissza gariba most

takyka:
a 3as port ragad be 1-en egy ido utan
2010-12-06
14:12:10
#9463
melyik az a port és melyik állapotban ragad be?
2010-12-06
12:27:17
#9459
zsezse,
Várd meg az új panelt, ha avval működik, akkor ez mehet gariba, vagy/és bugreport.
2010-12-06
12:23:40
#9457
én is 10.03at használok,nem hinnem,h ez a gond:(
Csak 1 pin ragad be,de amint inicializálom azonnal.
2010-12-06
10:20:59
#9452
Ez durván hangzik! Nem lehet, hogy frissíted a gpio, valamint a related modulokat és ott lesz verzióeltérés a kernelhez képest? Én a 10.03, r20728 -at használom, csomagtelepítésnél is maradok az adott verzión belül.

T.
2010-12-06
08:04:15
#9441
a reboot nem segit,csak az ujraflashelés,de már a 2. Firmwaret probálom,és mindig elöjön.
2010-12-05
21:47:23
#9435
Egyenlőre nem tapasztaltam ilyet.
a GPIO7 -t használom huzamosabban az 1 vezeték illesztő táp ki-be kapcsolására. Nem sokszor kapcsolgattam, de eddig nem volt probléma. A napokban kezdtem el használni a GPIO5-öt bemenetként, a HMV cirkuláció-indító gombnak, de azzal sem tapasztaltam ilyet. Az újraindítás segít, vagy csak az újratelepítés?
Nem egyszerű az élet. Én 1W I/O-t használok ahol csak lehet, de azoknál meg nem megy a lábankénti írás olvasás, csak "byteosan" így mindig maszkolnom kell, ha csak egy lábbal foglalkozom

T.
2010-12-05
19:39:12
#9432
takyka
jartal mar ugy, hogy beragadt valamelyik GPIO port?
nekem a pro-n a 3-as port rendszeresen beragad 1-re, es nem tudok rajonni, miert.

ha ujraflashelem, akkor egy darabig jo, de utana megint beragad, tobb firmware-rel is.
ma pl egesz nap megyegetett, de estere meghulyult
a direction out, de hiaba irok bele 0-at nem valt at:(
az RSen meg elindult a LAN2 port:D ha az RSPro -val kotottem ossze.
2010-12-03
22:59:07
#9374
no, beroffentettem az RSt:) a vezerlesre.
forrasztottam neki tuskesort, meg egy atalakitot az LPT portra, igy barmikor visszaterhetek a regi notebookra, ha szukseges, es a vezerlest sem kellett nagyon atalakitanom.
egyedul annyit, hogy az LPT-n 8 portom volt, itt csak 7, de usse kavics. legalabb marad 1 tartalek portom minden panelen.

viszont az RSPRO valamiert hulyeskedik az egyik GPIO porton.. nem tudom miert, ra kell csekkeljek.
jo lenne azzal osszeloni.

azzal meg a WIFIt nem tudom beallitani kliens modba:(

Biosolar Forum  =>  Mérésadatgyűjtés  =>  Single Board Computer - 1Wirelapozz: « előző   1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34   következő »
Copyright © 2005-2017 Bernáth Róbert
Minden jog fenntartva